Back to overview
Degraded

Order Creation Failures and Orders unavailable on FlexyPe Dashboard

Nov 25 at 04:35pm IST
Affected services
Checkout

Resolved
Nov 25 at 04:54pm IST

Order creation has now stabilized and processing is back to normal. We’re continuing to monitor the system and ensure all duplicate orders created during the affected window are cancelled.

Updated
Nov 25 at 04:50pm IST

We’ve identified that our retry mechanism triggered multiple times for some orders during this period, resulting in duplicate order creations. Our system will automatically detect and cancel those duplicates over the next few hours.

Updated
Nov 25 at 04:46pm IST

We’re working on clearing the pending orders currently sitting in our processing queue.

Updated
Nov 25 at 04:43pm IST

We’ve increased the throughput tier for the affected AWS services. Order creation is stabilizing, and we’re continuing to monitor the system closely.

Updated
Nov 25 at 04:40pm IST

Our initial investigation indicates that some AWS services rate-limited us. Because of this, orders are being created on Shopify but not reflected in our dashboard, and customers are not being redirected to the Thank You page after completing their purchase.

Created
Nov 25 at 04:35pm IST

We’re currently seeing some failed order creations. Our team is actively investigating the issue.